This project is read-only.

Simple Injector 2.0 for .NET 4.0 and up.

Jan 19, 2013 at 8:08 PM

I'm currently working on the next major release of Simple Injector and I'm thinking about dropping support for .NET 3.5 (the 1.x branch will still stay compatible with 3.5). Is anyone still developing applications using Simple Injector on .NET 3.5?

Jan 22, 2013 at 6:02 PM

I would take lack of response as "no" and rock on with 4.0 ;)

Marked as answer by dot_NET_Junkie on 11/5/2013 at 7:37 AM
Mar 7, 2013 at 6:51 PM
I am interested. Per customer constraint, we are stuck at .NET 3.5.
Mar 9, 2013 at 11:30 AM
I'm sorry Philippe, but Simple Injector 2.0 has been released and is .NET 4.0 only. Moving to .NET 4.0 help us solving some bugs and limitations that were otherwise very hard to fix. We will still fix bugs on the 1.6 branch (where possible) but don't expect any new features on that branch.